Page 1 of 1

Trying to post in "ChrisPC Free VPN" but forum is closed?

Posted: 06 Apr 2021, 21:42
by RockThePalladium
Is this an accident? I don't see a "Post" button.

This is first time trying to use VPN. I don't watch YouTube Videos because it's owned by Google. (Google "fingerprints" computers via Cloudflare.)

It seems no VPNs work, even those without passwords. I get "couldn't create tunnel". I'm using the latest version (downloaded today). Is ChrisPC VPN defunct? Or was forum closure an accident?

The "get new password" link takes you to each provider's website, where most of them don't have passwords. But I literally looked at one that said they don't require passwords (but it was from a site that had the link) nor registration. Their newest instructions are for Windows 8 but it uses Windows own setup, not ChrisPC or other software.

I'm very confused. :blink: Do I need to do both?
Or does anyone have recommedations on which site is easiest to connect to and most reliable?
I can't say I tried every one, but I tried a bunch.

Re: Trying to post in "ChrisPC Free VPN" but forum is closed

Posted: 15 Apr 2021, 19:11
by RockThePalladium
So I think I have solved the IP/DNS issue (not using the VPN software specifically) as much as possible... seems the cause really is DNS-filtering by ISPs! I can verify this by hitting and after connecting via ChrisPC Anonymous Connection. (In fact, I can't even connect to when my DNS is being redirected!)

The reason Anonymous Connection doesn't get overridden is because DNS servers + IP proxies are wrapped into one package, and even the DNS ARP requests must be encrypted, I imagine. (Being encrypted, they're not getting filtered because ISPs have no way to know that they are ARP requests.)

Unfortuately AC causes problems with my browser (old FF spinoff w/legacy add-ons) where when I close it, the process never stops and I must kill it with Task Manager, which stinkis because the next time I start the browser, it wants to recover my crashed session and the tabs are maybe being sent the normal way (depending where/how I'm connected at the moment). I finally figured out the non-closing process is solved by opening the browser first, before AC. :blink: Why? I have no idea! But if I start the browser first, AC doesn't prevent it from properly closing.

So, to recap:
Use Anonymous Connection due to combination of DNS/proxy + encrypted DNS.
Open the browser before connecting